Help & Support

Energy Online

What are the compatibility requirements for Energy Online?

In order to get the best possible experience whilst using Energy Online please consider the following:

  • Use the latest versions of Chrome, Firefox and Safari browsers or Internet Explorer 9 or above
  • Your browser must support a minimum of TLS 1.0
  • Check your Operating System is either Windows (7, 8, 8.1, 10), Mac OS X, iOS 8 or higher or Android 4.4 or higher
  • JavaScript, Cookies and CSS must all be enabled